Got the 401 twin turbo running

Tech Related Discussion

Got the 401 twin turbo running

Postby Orr89rocz » Fri Jun 29, 2012 8:16 pm

Well got the car 90% complete. Its idling but I need to finish few other things before its driveable. Working on the tune. Got the EFI cold and hot starting worked out and idle tune is coming along. Still abit rich but stable and comfortable for now. Lots of tuning work left ahead but my main issue is some valvetrain or other noise around passenger side valvecover.
I dont think it is lifter noise or rocker noise now since I rechecked the preload and everything was in spec and nuts on rockers tight. Nothing loose. Sounds like something is hitting valve cover but didnt see marks underneath or on the rockers and driver side aint doing it so not sure. Dont think its exhaust leak because I never quite heard it like this but I wont rule that out...i'll do some investigating. It does change with rpm in sync so it could very well be a leak. I had 2 years ago with old combo that I thought was a lifter. Oh well, will figure it out.

Its a Dart SHP 400 block. Chad Speier's v2.72's with girly cam :) Bauer hyd roller but its big. ~10" Hg at idle 950-1000 rpm right now. Turbo hotside/coldside all designed/built by me and tuned by me.

OLD setup was AFR 195's and mild 233 deg .564" hyd roller. More restrictive log/hybrid turbo manifold. Its been 9.8's at 141 mph in a 3550-3600 lb setup leaving off idle, 1.56 60 foot :) Just 14psi and 93 oct. Hope to see 150mph traps easily with this setup on straight pump gas. It should scooot for a street car

Big thanks to all that helped. Chad and Bret with the heads/cam advice. Think I ended up with a winner
Image

http://www.youtube.com/watch?v=nwRHxh1smQU
Orr89rocz
 
Posts: 72
Joined: Tue Jul 26, 2011 4:40 pm

Re: Got the 401 twin turbo running

Postby Orr89rocz » Fri Aug 10, 2012 7:13 am

Have been doin some drive tuning. Alot of my part throttle areas are good but still need fine tuned to be perfect. Intial impressions are good. Despite such a big head and cam conpared to the old setup it drives extremely well and actually docile. Very nice. On heavier throttle accel from a stop i am happy to say i think this combo has more pep than the small head cam setup. Its not even fully tuned as some spots are too rich but never would have expected such combo to have this kind of response at lower mid rpms and part throttle. Completely throws the big heads dont make torque out the window imo. Car scoots nicely even with 2.73 gears for now.
I have been up to 6 psi boost but my map is way rich so its not coming alive just yet. But even with such large turbo housings compared to last setup this thing is spooling sooo early. 3500 rpm and just over 65-70% throttle is practically at full 6 psi. Its nuts. Didnt expect it to light turbos that quick already but thats good! I will take it. Hope to lean it out tonight and really start pushing the rpms. Havent been over 4000 yet and it feels strong
Orr89rocz
 
Posts: 72
Joined: Tue Jul 26, 2011 4:40 pm

Re: Got the 401 twin turbo running

Postby Chad Speier » Tue Aug 21, 2012 7:45 am

Get on it! :)
Chad Speier
Image
Chad Speier
 
Posts: 1846
Joined: Mon Nov 12, 2007 6:03 pm
Location: Hays, Kansas

Re: Got the 401 twin turbo running

Postby SStrokerAce » Wed Aug 22, 2012 11:35 pm

Sounds good to me so far! :mrgreen:
SStrokerAce
 
Posts: 360
Joined: Wed Apr 15, 2009 9:13 am

Re: Got the 401 twin turbo running

Postby Orr89rocz » Mon Aug 27, 2012 11:04 am

Car is running good enough to get some dyno and or track time this week. Baseline runs so i dont expect record performance so let me get some seat time and tuning time but will keep you posted. I suffered an ecm failure last week and have my back up in. If it wasnt for that id have track time on it this past week.

Keep in mind i do not have trans brake and will be on 19" drag radials with low 6psi boost launch ramping in thru first so it may not show 60's yet. Still in street trim i dont have the bigs littles ready yet. I still havent got my 12 bolt in and it still has 2.73 highway gears. Car wants more to spool. It wakes up over 4k rpm. My converter is about 3000 off boost and opens to 3600 with few psi and about 4000 from what i can tell on 6+ off a slow roll stab.

Fuel curve is insane above 5600. Between 4-5600 is rich so i am taking fuel out but after 5600-5800 its starting to get thirsty. 6000+ its leaning out alot so i have to add alot of fuel. Power up top must be unreal. We shall see. Only seen 9 psi so far but feels good
Orr89rocz
 
Posts: 72
Joined: Tue Jul 26, 2011 4:40 pm

Re: Got the 401 twin turbo running

Postby Orr89rocz » Wed Oct 10, 2012 9:29 am

Just an update. Been awhile. Been tuning alittle and worked it up to 12 psi but timing was conservative. I tried getting it to track on stock 2.73 rear end and car cant launch. Turbos need 3800-4000 rpm to spool and i can only get 3500 for few seconds before it starts picking up speed. Going to restall it but only pass i did make was 11.85 at 128 literally rolling out like a grandma. 2.0 60 ft waiting for spool. It didnt come alive until sometime 150 ft out and with the gears i barely got into 3 rd before the stripe haha. Still hit 99 by 1/8 starting from 150 ft out atleast. Still rich on top end and no timing in it. After few more days of driving and tuning i have added over 5 deg timing and its picking up. Still wants more. Swapped in 3.42 12 bolt rear and it feels awesome. However my axle bearing went bad and rear is leaking.
Working on replacing that should be done soon.

Bought a nitrous kit to spray off line to temporarily fix my spool issue. Just got that in. Now my gas tank is dripping fuel. Connections at intank pumps at top must be loose so i gotta drop it.
Just havent had much time last month and a half it seems. My b&m shifter broke so i bought a turbo action cheetah. Its mounted but needs connected at trans. Frantically trying to get it together for test n tune a we only have few more weeks left i hear and to give you guys some results!

Either way the tune is getting much stronger and i can feel a huge difference. Timing is more aggressive than my old heads setup so i am trying to find the sweet spot.
Orr89rocz
 
Posts: 72
Joined: Tue Jul 26, 2011 4:40 pm

Re: Got the 401 twin turbo running

Postby Chad Speier » Sat Dec 08, 2012 9:03 am

Make any progress???
Chad Speier
Image
Chad Speier
 
Posts: 1846
Joined: Mon Nov 12, 2007 6:03 pm
Location: Hays, Kansas

Re: Got the 401 twin turbo running

Postby Orr89rocz » Thu Dec 20, 2012 7:20 pm

Took a break working on this car and just got back to it this weekend. Engine is finally out of the car and ready to go on the stand for disassembly and I can inspect the cylinders to see what caused my 2 grooves cut into the bore. Only on cylinder 5 and 6, 6 being the worst.

I'm gonna look at the heads to see if maybe any of the guide material or whatnot fell into the bore. If its not that, maybe it was the rings getting bunched up with the chamber heat as I did get alittle aggressive with it.

I hope it hones out and doesnt require rebore. Then I'm going to open gaps up so it will be better off for more boost. I plan to push this to 1000 at the tires. I figure it was in the 750 range on low boost in its current trim, with it not even getting to peak hp rpms.

Switching EFI systems. Keeping same intake setup but going to run an LS1 411 ecm and 24x crank ring and coil packs per cylinder. Hope to get abit more tuneability out of the setup.

Going to install trans brake and open up the convert 500 rpms or so. It was just a touch too low for the setup. I used nitrous to spool it and that small few hundred rpm flash on the 75 shot instantly spooled.
Orr89rocz
 
Posts: 72
Joined: Tue Jul 26, 2011 4:40 pm

Re: Got the 401 twin turbo running

Postby Orr89rocz » Tue Feb 11, 2014 7:08 am

Just an update since i havent been here in awhile. This past november 2013 i got the combo back together. As stated above, refreshed the heads and shortblock, added shaft rockers, switched to new efi system, and got everything running.

401" with about 9:1 compression. Speier v2.72 rhs castings, Bauer hyd roller, victor E Efi. Twin 70mm t4 turbos, dual 3" exhaust with 4 mufflers total and x pipe. Th400, ptc 4500 stall. Thats the basics

Happy to report valvetrain issues i had year before from improper pushrod setup are gone. Valvetrain stable to 7200 rpms, even on 24 psi

On pump 93 and cold winter day we dyno tuned it to 1018/851 whp wtq uncorrected on 24.5 psi boost. 1009/844 corrected sae. Enjoy the vid

Probably have 50-70 whp if i dumped exhaust to larger pipes or just open downs. Race gas or meth injection i hope can add 50-100. Like to see 1200 whp out of it
http://www.youtube.com/watch?v=n1oG0I04x60
Orr89rocz
 
Posts: 72
Joined: Tue Jul 26, 2011 4:40 pm


Return to General Talk

Who is online

Users browsing this forum: No registered users and 1 guest

cron